How to install svn 1.6 for centos 5.5:
First enable the rpmforge repo (repository – a place for “rpm” packages),
then you can just install using yum. Note that after I installed the subversion, I then disabled the repo to keep my install as close to CentOS as I can.

wget http://dag.wieers.com/rpm/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

rpm -ivh rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

yum install subversion.x86_64

You can disable the rpmforge repo in /etc/yum.repos.d/rpmforge.repo
and changed enabled = 1 to enabled = 0

3 Comments

  1. Green says:

    Hi

    I tried to follow the instruction but always end up with this error message:

    No package subversion.x86_64 available.

  2. Green says:

    The solution is exclude subversion in each entry of /etc/yum.repo.d/CentOS-Base.repo and then simply run

    yum install subversion

    it will pull svn 1.6 from rpmforge repo

  3. jack says:

    FYI, it looks like it’s now in rpmforge-extras

    yum –enablerepo=rpmforge-extras list available | grep subversion

    subversion.x86_64 1.6.15-0.1.el5.rfx rpmforge-extras
    subversion-devel.i386 1.4.2-4.el5_3.1 base
    subversion-devel.x86_64 1.6.15-0.1.el5.rfx rpmforge-extras
    subversion-javahl.x86_64 1.6.15-0.1.el5.rfx rpmforge-extras
    subversion-perl.x86_64 1.6.15-0.1.el5.rfx rpmforge-extras
    subversion-ruby.x86_64 1.6.15-0.1.el5.rfx rpmforge-extras

    My installed rpmforge-release version is:
    Installed Packages
    Name : rpmforge-release
    Arch : x86_64
    Version : 0.5.2
    Release : 2.el5.rf

Leave a Reply